扫描二维码,下载手机APP
下载安卓APP箭头
客服QQ
箭头给我发消息

客服QQ:3315713922

Access、Truck和Hybrid三种端口模式的区别

作者:课课家教育 http://www.kokojia.com点击数:18383发布时间:2018-01-08 16:00:53
软考,您想通过吗?一次通过才是硬道理

  以太网端口有三种链路类型:Access、Truck和Hybrid。这三种链路类型的连接终端有所区别。不是很了解由想学习的朋友,下面就和我们一起来学习吧!
  Access端口:
  一般连接主机
  只允许与该端口的PVID相同的VLAN通过,收到untagged的数据帧,强制打上本端口PVID的标签;
  Trunk端口:
  一般用于交换机之间的连接
  在交换机之间传递tagged frame。允许多个VLAN通过,可以与PVID不同
  收到不带tagged frame的数据帧时,打上PVID 并转发
  收到带tagged frame数据帧时,检查VLAN ID,如果允许并且VLAN ID与PVID相同,去掉tagged直接转发,如果允许并且VLAN ID与PVID不同,直接转发原数据帧。
  Hybrid端口:
  华为交换机的缺省端口模式。可以当做Access端口连接主机使用,也可以当做trunk使用
  此端口的转发模式与trunk端口一样,允许多个VLAN通过,收到不带tagged frme,打上pvid标签并转发
  收到带tagged frame时,如允许并且VLAN ID与PVID相同,除去标签转发,如允许并且VLAN ID与PVID不同,直接转发
  hybrid允许多个VLAN报文不打标签发送,但是trunk端口只允许与自己PVID相同的VLAN报文发送时不打标签;
  当Hybrid端口没有tagged VLAN,untagged VLAN只有一个时,功能与access端口一样;当Hybrid端口没有untagged VLAN时,功能与trunk端口一样。
  下面就通过几个简单的例子来了解Access、Truck和Hybrid配置和工作原理。
  Access
  Access、Truck和Hybrid三种端口模式的区别_服务器_通信_交换机_课课家教育
  [SwitchA]vlan 2
  指定端口E0/2端口类型为accesss属于vlan2
  [SwitchA]interface ethernet 0/2
  [SwitchA-Ethernet1]port access vlan 2
  [SwitchA]vlan 3
  指定端口E0/10类型为access属于vlan10
  [SwitchA]interface ethernet 0/10
  [SwitchA-Ethernet2]port access vlan 10
  特点以及注意事项:
  (1)缺省情况下所有端口都属于VLAN 1,并且端口是access端口,一个access端口只能属于一个vlan;
  (2)如果端口是access端口,则把端口加入到另外一个vlan的同时,系统自动把该端口从原来的vlan中删除掉;
  Trunk
  交换机_服务器_通信
  实验目的:
  1. sw1和sw2之间相同vlan可以通信
  2. sw1和sw2之间不相同vlan不可以通信
  实验过程:
  sw1配置
  设置vlan并把端口加入vlan
  [sw1]vlan10
  [sw1-vlan10]port e0/1
  [sw1-vlan10]vlan 20
  [sw1-vlan20]port e0/2
  设置e0/24为trunk
  [sw1-vlan20]interface e0/24
  [sw1-Ethernet0/24]port link-type trunk
  [sw1-Ethernet0/24]port trunk permit vlan 10 20
  Sw2配置
  设置vlan并把端口加入vlan
  [sw2]vlan10
  [sw2-vlan10]port e0/10
  [sw2-vlan10]vlan 20
  [sw2-vlan20]port e0/20
  设置e0/24为trunk
  [sw2-vlan20]interface e0/24
  [sw2-Ethernet0/24]port link-type trunk
  [sw2-Ethernet0/24]port trunk permit vlan 10 20
  特点以及注意事项:
  (1)如果一个端口是trunk端口,则该端口可以属于多个vlan;
  (2)缺省情况下trunk端口的PVID为1,可以在端口模式下通过命令port trunk pvid vlan vlanid 来修改端口的PVID;
  (3)如果从trunk转发出去的数据报文的vlan id和端口的PVID一致,则该报文的VLAN信息会被剥去,这点在配置trunk端口时需要注意。
  (4)一台交换机上如果已经设置了某个端口为hybrid端口,则不可以再把另外的端口设置为trunk端口。
  (5)一般情况下最好指定端口允许通过哪些具体的VLAN,不要设置允许所有的VLAN通过。
  Hybrid
  服务器_端口_通信
  实验目的:
  1. pc1、pc2、pc3都可以访问服务器
  2. pc1和pc2可以互访
  3. pc1和pc3可以互访
  4. pc2和pc3不可以互访
  实验过程
  创建vlan并将端口加入vlan
  [sw1]vlan10
  [sw1-vlan10]port e0/1
  [sw1-vlan10]vlan 20
  [sw1-vlan20]port e0/2
  [sw1-vlan20]vlan30
  [sw1-vlan30]port e0/3
  [sw1-vlan20]vlan 100
  [sw1-vlan20]port e0/24
  设置e0/1 为hybrid,能够接收vlan 20 30 100 的报文
  [sw1-vlan20]int e0/1
  [sw1-Ethernet0/1]port link-type hybrid
  [sw1-Ethernet0/1]port hybrid vlan 20 30 100 untagged
  设置e0/2 为hybrid,允许vlan10 100通过
  [sw1-Ethernet0/1]int e0/2
  [sw1-Ethernet0/2]port link-type hybrid
  [sw1-Ethernet0/2]port hybrid vlan 10 100 untagged
  设置e0/2 为hybrid,能够接收vlan10 100 的报文
  [sw1-Ethernet0/2]int e0/3
  [sw1-Ethernet0/3]port link-type hybrid
  [sw1-Ethernet0/3]port hybrid vlan 10 100 untagged
  设置e0/24为hybrid 能够接收vlan10 20 30 的报文
  [sw1-Ethernet0/3]int e0/24
  [sw1-Ethernet0/24]port link-type hybrid
  [sw1-Ethernet0/24]port hybrid vlan 10 20 30 untagged
  今天的学习就到这了,你能区分Access、Truck和Hybrid?

赞(19)
踩(1)
评论(0
最新评论

暂无评论~

大数据课程